[Dspam-user] Can't train DSPAM on my test setup

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Dspam-user] Can't train DSPAM on my test setup

Орхан Касумов

Hello, DSPAM users!
I've got a problem, can't train DSPAM on my test setup - when moving a mail from Inbox to SPAM, Thunderbird says:

"The current operation on 'Inbox' did not succeed.
The mail server for account [hidden email] responded: [CANNOT]
Failed to call dspam."

My test setup is on a single VM called "mail.examplee.com" running FreeBSD 10.0; it has the following services:

- named (bind910-9.10.1P1_1)
- apache24 (apache24-2.4.10_2)
- mysql (mysql55-server-5.5.41)
- postfix (postfix-2.11.3_3,1)
- dovecot (dovecot2-2.2.15_2, dovecot-pigeonhole-0.4.6, dovecot2-antispam-plugin-20130429_9)
- dspam (dspam-3.10.2)

I have only two mailboxes in domain "examplee.com": [hidden email] and [hidden email]. They can send mails to each other, and DSPAM inserts its fields (X-DSPAM-...) into headers. But when I try to move a mail sent by user1 from Inbox of user2 to SPAM folder of user2, I get the error message provided above.

I suppose that it may be caused by a problem in Dovecot - Antispam plugin interaction, but need help to figure out what is really wrong.

DSPAM was built with these options:
[*] SYSLOG Logs via syslog
[*] DEBUG Enable debugging logging
[*] DAEMON Daemonize dspam; speaks LMTP
[*] HASH Use hash driver
[*] POSTFIX_MBC Dspam as mailbox_command Postfix

Postfix was built with these options:
[*] PCRE Perl Compatible Regular Expressions
[*] DOVECOT2 Dovecot 2.x SASL authentication method
[*] TLS Enable SSL and TLS support
[*] MYSQL MySQL maps (uses WITH_MYSQL_VER)

Dovecot was built with [*] MYSQL option.

Dovecot, Postfix and DSPAM configurations are in this archive:
https://cloud.mail.ru/public/874d35cb38bc/mail-dspam.zip 

Please take time to review configs and help me with this problem - any help is highly appreciated!
Thanks in advance!


------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Can't train DSPAM on my test setup

Sparr
DSPAM and Postfix have a problem playing nicely together with the IMAP APPEND command, which is what's used when you move a message into an account. The default configuration when they are used together is to disable that command for the spam folder, which means you can't drag mails between accounts into the spam folder.


On Thu, Jan 22, 2015 at 9:54 AM, Орхан Касумов <[hidden email]> wrote:

I have only two mailboxes in domain "examplee.com": [hidden email] and [hidden email]. They can send mails to each other, and DSPAM inserts its fields (X-DSPAM-...) into headers. But when I try to move a mail sent by user1 from Inbox of user2 to SPAM folder of user2, I get the error message provided above.

I suppose that it may be caused by a problem in Dovecot - Antispam plugin interaction, but need help to figure out what is really wrong.


------------------------------------------------------------------------------
New Year. New Location. New Benefits. New Data Center in Ashburn, VA.
GigeNET is offering a free month of service with a new server in Ashburn.
Choose from 2 high performing configs, both with 100TB of bandwidth.
Higher redundancy.Lower latency.Increased capacity.Completely compliant.
http://p.sf.net/sfu/gigenet
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user