[Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

classic Classic list List threaded Threaded
26 messages Options
12
Reply | Threaded
Open this post in threaded view
|

[Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Guillaume Hilt-2
     Hello,

I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
up-to-date).
As Dspam still use the old mysql library, i'm trying to re-emerge it :

!!! existing preserved libs:
 >>> package: dev-db/mysql-5.5.32
  *  - /usr/lib64/libmysqlclient.so.16
  *  - /usr/lib64/mysql/libmysqlclient.so.16
  *  - /usr/lib64/mysql/libmysqlclient.so.16.0.0
  *      used by /usr/lib64/dspam/libmysql_drv.so.7.0.0
(mail-filter/dspam-3.10.2

But it fails with this error :
configure: error: Required version of libmysqlclient not found

$ emerge -pqv '=mail-filter/dspam-3.10.2-r1::gentoo'
[ebuild   R   ] mail-filter/dspam-3.10.2-r1  USE="clamav daemon
domain-scale mysql syslog virtual-users -debug -hash -large-scale -ldap
-postgres -small-scale -sqlite -static-libs -user-homedirs"

$ locate libmysqlclient
/usr/lib64/libmysqlclient.so.16
/usr/lib64/mysql/libmysqlclient.a
/usr/lib64/mysql/libmysqlclient.so
/usr/lib64/mysql/libmysqlclient.so.16
/usr/lib64/mysql/libmysqlclient.so.16.0.0
/usr/lib64/mysql/libmysqlclient.so.18
/usr/lib64/mysql/libmysqlclient.so.18.0.0
/usr/lib64/mysql/libmysqlclient_r.a
/usr/lib64/mysql/libmysqlclient_r.so
/usr/lib64/mysql/libmysqlclient_r.so.18
/usr/lib64/mysql/libmysqlclient_r.so.18.0.0


$ ls /usr/lib64/mysql/libmysql*
-rw-r--r-- 1 root root 3,5M  9 sept. 13:02 libmysqlclient.a
lrwxrwxrwx 1 root root   16  9 sept. 13:02 libmysqlclient_r.a ->
libmysqlclient.a
lrwxrwxrwx 1 root root   17  9 sept. 13:02 libmysqlclient_r.so ->
libmysqlclient.so
lrwxrwxrwx 1 root root   17  9 sept. 13:02 libmysqlclient_r.so.18 ->
libmysqlclient.so
lrwxrwxrwx 1 root root   17  9 sept. 13:02 libmysqlclient_r.so.18.0.0 ->
libmysqlclient.so
lrwxrwxrwx 1 root root   20  9 sept. 13:02 libmysqlclient.so ->
libmysqlclient.so.18
lrwxrwxrwx 1 root root   24  2 juil. 14:12 libmysqlclient.so.16 ->
libmysqlclient.so.16.0.0
-rwxr-xr-x 1 root root 1,6M  2 juil. 14:12 libmysqlclient.so.16.0.0
lrwxrwxrwx 1 root root   24  9 sept. 13:02 libmysqlclient.so.18 ->
libmysqlclient.so.18.0.0
-rwxr-xr-x 1 root root 2,9M  9 sept. 13:02 libmysqlclient.so.18.0.0
-rw-r--r-- 1 root root 4,4K  9 sept. 13:02 libmysqlservices.a


$ ls /usr/lib64/libmysql*
lrwxrwxrwx 1 root root 30  2 juil. 14:12 libmysqlclient.so.16 ->
mysql/libmysqlclient.so.16.0.0

I already tried to ask on Gentoo reply but no luck so far.

Any idea ?

Thanks,

--
   Guillaume Hilt


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Tom Hendrikx
On 11/08/2013 10:05 AM, Guillaume Hilt wrote:

>      Hello,
>
> I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
> up-to-date).
> As Dspam still use the old mysql library, i'm trying to re-emerge it :
>
> !!! existing preserved libs:
>  >>> package: dev-db/mysql-5.5.32
>   *  - /usr/lib64/libmysqlclient.so.16
>   *  - /usr/lib64/mysql/libmysqlclient.so.16
>   *  - /usr/lib64/mysql/libmysqlclient.so.16.0.0
>   *      used by /usr/lib64/dspam/libmysql_drv.so.7.0.0
> (mail-filter/dspam-3.10.2
>
> But it fails with this error :
> configure: error: Required version of libmysqlclient not found
>
Could you post more output from the failing build? Something like the
last 30 lines before this error occurs? this should nbe available in the
build.log, or in stdout when you use 'emerge -v dspam'.

> $ emerge -pqv '=mail-filter/dspam-3.10.2-r1::gentoo'
> [ebuild   R   ] mail-filter/dspam-3.10.2-r1  USE="clamav daemon
> domain-scale mysql syslog virtual-users -debug -hash -large-scale -ldap
> -postgres -small-scale -sqlite -static-libs -user-homedirs"
>
> $ locate libmysqlclient
> /usr/lib64/libmysqlclient.so.16
> /usr/lib64/mysql/libmysqlclient.a
> /usr/lib64/mysql/libmysqlclient.so
> /usr/lib64/mysql/libmysqlclient.so.16
> /usr/lib64/mysql/libmysqlclient.so.16.0.0
> /usr/lib64/mysql/libmysqlclient.so.18
> /usr/lib64/mysql/libmysqlclient.so.18.0.0
> /usr/lib64/mysql/libmysqlclient_r.a
> /usr/lib64/mysql/libmysqlclient_r.so
> /usr/lib64/mysql/libmysqlclient_r.so.18
> /usr/lib64/mysql/libmysqlclient_r.so.18.0.0
>
>
> $ ls /usr/lib64/mysql/libmysql*
> -rw-r--r-- 1 root root 3,5M  9 sept. 13:02 libmysqlclient.a
> lrwxrwxrwx 1 root root   16  9 sept. 13:02 libmysqlclient_r.a ->
> libmysqlclient.a
> lrwxrwxrwx 1 root root   17  9 sept. 13:02 libmysqlclient_r.so ->
> libmysqlclient.so
> lrwxrwxrwx 1 root root   17  9 sept. 13:02 libmysqlclient_r.so.18 ->
> libmysqlclient.so
> lrwxrwxrwx 1 root root   17  9 sept. 13:02 libmysqlclient_r.so.18.0.0 ->
> libmysqlclient.so
> lrwxrwxrwx 1 root root   20  9 sept. 13:02 libmysqlclient.so ->
> libmysqlclient.so.18
> lrwxrwxrwx 1 root root   24  2 juil. 14:12 libmysqlclient.so.16 ->
> libmysqlclient.so.16.0.0
> -rwxr-xr-x 1 root root 1,6M  2 juil. 14:12 libmysqlclient.so.16.0.0
> lrwxrwxrwx 1 root root   24  9 sept. 13:02 libmysqlclient.so.18 ->
> libmysqlclient.so.18.0.0
> -rwxr-xr-x 1 root root 2,9M  9 sept. 13:02 libmysqlclient.so.18.0.0
> -rw-r--r-- 1 root root 4,4K  9 sept. 13:02 libmysqlservices.a
>
>
> $ ls /usr/lib64/libmysql*
> lrwxrwxrwx 1 root root 30  2 juil. 14:12 libmysqlclient.so.16 ->
> mysql/libmysqlclient.so.16.0.0
>
> I already tried to ask on Gentoo reply but no luck so far.
>
> Any idea ?
>
> Thanks,
>


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user

signature.asc (919 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Tom Hendrikx
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256


Hi

[please  keep your replies on-list]

I tried to get some more details. config.log shows for the problematic
step:

[...]
configure:13560: checking for mysql_init in -lmysqlclient
configure:13583: x86_64-pc-linux-gnu-gcc -o conftest -O2 -pipe
- -I/usr/include/mysql    -Wl,-O1 -Wl,--as-needed  -rdynamic conftest.c
- -lmysqlclient   -pthread >&5
/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/../../../../x86_64-pc-linux-gnu/bin/ld:
cannot find -lmysqlclient
collect2: error: ld returned 1 exit status
configure:13583: $? = 1
configure: failed program was:
| /* confdefs.h */

[...]

| #define HAVE_ERRMSG_H 1
| /* end confdefs.h.  */
|
|             #include <stdlib.h>
|             #include <mysql.h>
|
| int
| main ()
| {
|
|             MYSQL *mysql = mysql_init(NULL);
|           mysql_close(mysql);
|
|   ;
|   return 0;
| }
configure:13591: result: no
configure:13678: error: Required version of libmysqlclient not found

The weird thing is that mysql.h for both 5.1.70 and 5.5.32 define
mysql_init in mysql.h, and both libmysqlclient.{a,so} files seem to
contain a mysql_init reference (according to strings).

I'm really sure where to look any further. I can reproduce but I've no
idea why it's failing...


Regards,
        Tom

On 08-11-13 12:56, Guillaume Hilt wrote:

> I put everything here :
> http://forums.gentoo.org/viewtopic-p-7432926.html#7432926
>
>
> Guillaume Hilt
>
> Le 08/11/2013 12:46, Tom Hendrikx a écrit :
>> On 11/08/2013 10:05 AM, Guillaume Hilt wrote:
>>> Hello,
>>>
>>> I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo
>>> AMD64 up-to-date). As Dspam still use the old mysql library,
>>> i'm trying to re-emerge it :
>>>
>>> !!! existing preserved libs:
>>>>>> package: dev-db/mysql-5.5.32
>>> *  - /usr/lib64/libmysqlclient.so.16 *  -
>>> /usr/lib64/mysql/libmysqlclient.so.16 *  -
>>> /usr/lib64/mysql/libmysqlclient.so.16.0.0 *      used by
>>> /usr/lib64/dspam/libmysql_drv.so.7.0.0
>>> (mail-filter/dspam-3.10.2
>>>
>>> But it fails with this error : configure: error: Required
>>> version of libmysqlclient not found
>>>
>> Could you post more output from the failing build? Something like
>> the last 30 lines before this error occurs? this should nbe
>> available in the build.log, or in stdout when you use 'emerge -v
>> dspam'.
>>
>>> $ emerge -pqv '=mail-filter/dspam-3.10.2-r1::gentoo' [ebuild
>>> R   ] mail-filter/dspam-3.10.2-r1  USE="clamav daemon
>>> domain-scale mysql syslog virtual-users -debug -hash
>>> -large-scale -ldap -postgres -small-scale -sqlite -static-libs
>>> -user-homedirs"
>>>
>>> $ locate libmysqlclient /usr/lib64/libmysqlclient.so.16
>>> /usr/lib64/mysql/libmysqlclient.a
>>> /usr/lib64/mysql/libmysqlclient.so
>>> /usr/lib64/mysql/libmysqlclient.so.16
>>> /usr/lib64/mysql/libmysqlclient.so.16.0.0
>>> /usr/lib64/mysql/libmysqlclient.so.18
>>> /usr/lib64/mysql/libmysqlclient.so.18.0.0
>>> /usr/lib64/mysql/libmysqlclient_r.a
>>> /usr/lib64/mysql/libmysqlclient_r.so
>>> /usr/lib64/mysql/libmysqlclient_r.so.18
>>> /usr/lib64/mysql/libmysqlclient_r.so.18.0.0
>>>
>>>
>>> $ ls /usr/lib64/mysql/libmysql* -rw-r--r-- 1 root root 3,5M  9
>>> sept. 13:02 libmysqlclient.a lrwxrwxrwx 1 root root   16  9
>>> sept. 13:02 libmysqlclient_r.a -> libmysqlclient.a lrwxrwxrwx 1
>>> root root   17  9 sept. 13:02 libmysqlclient_r.so ->
>>> libmysqlclient.so lrwxrwxrwx 1 root root   17  9 sept. 13:02
>>> libmysqlclient_r.so.18 -> libmysqlclient.so lrwxrwxrwx 1 root
>>> root   17  9 sept. 13:02 libmysqlclient_r.so.18.0.0 ->
>>> libmysqlclient.so lrwxrwxrwx 1 root root   20  9 sept. 13:02
>>> libmysqlclient.so -> libmysqlclient.so.18 lrwxrwxrwx 1 root
>>> root   24  2 juil. 14:12 libmysqlclient.so.16 ->
>>> libmysqlclient.so.16.0.0 -rwxr-xr-x 1 root root 1,6M  2 juil.
>>> 14:12 libmysqlclient.so.16.0.0 lrwxrwxrwx 1 root root   24  9
>>> sept. 13:02 libmysqlclient.so.18 -> libmysqlclient.so.18.0.0
>>> -rwxr-xr-x 1 root root 2,9M  9 sept. 13:02
>>> libmysqlclient.so.18.0.0 -rw-r--r-- 1 root root 4,4K  9 sept.
>>> 13:02 libmysqlservices.a
>>>
>>>
>>> $ ls /usr/lib64/libmysql* lrwxrwxrwx 1 root root 30  2 juil.
>>> 14:12 libmysqlclient.so.16 -> mysql/libmysqlclient.so.16.0.0
>>>
>>> I already tried to ask on Gentoo reply but no luck so far.
>>>
>>> Any idea ?
>>>
>>> Thanks,
>>>
>>
>>
>>
>> ------------------------------------------------------------------------------
>>
>>
>>
November Webinars for C, C++, Fortran Developers

>> Accelerate application performance with scalable programming
>> models. Explore techniques for threading, error checking,
>> porting, and tuning. Get the most from the latest Intel
>> processors and coprocessors. See abstracts and register
>> http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
>>
>>
>>
>>
>>
_______________________________________________
>> Dspam-user mailing list [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/dspam-user
>
>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.14 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJSfn98AAoJEJPfMZ19VO/1NlcP/0AmKFsitcQtrcucLAuEPX6d
1GLDPoo5UOGCaLBxWKDDr46b4/s70YQgdD4njPgfztSBW9SkB7AqKtZTU23rbZLZ
zbt5sFMxp8VSw8ZDLR7OHJC4jh5MBO5PTQWQ9axh0r59zSq9w1Q42kwSlbw4Mcvx
jCdBs2ODO/tKjHRNRIQ2EBfye/SQtiEXSVquFcuq9bwhGnNx8GozrcyguMVP7C3i
Y1xq4KpGfisdeBSxBFYWrjA0hbajUIkkLCZryKb7iN26ixFbxEWqzFO3Ta8N9Rbl
0nVCUuYHnySzgqAt+NzJZ024qQ1h+MfFABoyYmms16SEpOKb34SX9wvDnsqk2I5M
8wrgflzX9K6PWjzg36ch9/MMizM+RajpMID2rqJ98/UYyVt4AvVVbsbQfp5y1fkf
BZz/ZH5A5g5xe8H3PlPFlLBYmyA/5Le186LYhTThUn5sq33s0bs+Q7pFTDwJ2nfi
cWk7stwpAwcDzOGOLBjhhVKaak6tww4SvxEW3W9JhIhzCfLa4NQVp37iGbI7UbaA
nYid8fasChMsKkaUwRmXeOtBzfFf+kN42i/RZU48PxfajCAqlycJ+BQQxHbz9Sd6
N99t1TualD1cS367FUkB3E6sArs+TdOdG+JWa09TXzA0TR03FETtDDvTMX0IXxZ1
44ie44MrGj+u1fu6JGdH
=Eh+8
-----END PGP SIGNATURE-----

------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Benny Pedersen-2
In reply to this post by Guillaume Hilt-2
Guillaume Hilt skrev den 2013-11-08 10:05:

> I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
> up-to-date).

is mysql 5.5 unmasked now ?

here is just 5.1 on both of my gentoo servers

block 5.5 and remerge dspam, but maybe need to emerge stable mysql first
?

in any case make a bog on gentoo that dspam blocks mysql 5.5 would be
essential



------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Guillaume Hilt-2
5.5 is still in testing.
Since I use it on my main mysql server (ubuntu 12.04), i have to use it
on this one too.

I'll post a bug tomorrow.

   Guillaume Hilt

Le 11/11/2013 01:23, Benny Pedersen a écrit :

> Guillaume Hilt skrev den 2013-11-08 10:05:
>
>> I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
>> up-to-date).
> is mysql 5.5 unmasked now ?
>
> here is just 5.1 on both of my gentoo servers
>
> block 5.5 and remerge dspam, but maybe need to emerge stable mysql first
> ?
>
> in any case make a bog on gentoo that dspam blocks mysql 5.5 would be
> essential
>
>
>
> ------------------------------------------------------------------------------
> November Webinars for C, C++, Fortran Developers
> Accelerate application performance with scalable programming models. Explore
> techniques for threading, error checking, porting, and tuning. Get the most
> from the latest Intel processors and coprocessors. See abstracts and register
> http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
> _______________________________________________
> Dspam-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/dspam-user
>


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Phil Stracchino
On 11/11/13 12:46, Guillaume Hilt wrote:
> 5.5 is still in testing.

Is it just me, or is it slightly ridiculous for MySQL 5.5 to be "still
in testing" three years after its official general-availability release?


--
  Phil Stracchino
  Babylon Communications
  [hidden email]
  [hidden email]
  Landline: 603.293.8485

------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Benny Pedersen-2
In reply to this post by Guillaume Hilt-2
Guillaume Hilt skrev den 2013-11-11 18:46:
> 5.5 is still in testing.

+1

> Since I use it on my main mysql server (ubuntu 12.04), i have to use it
> on this one too.

well without testers it would never be stable, so super one take the
time

> I'll post a bug tomorrow.

why wait ? :=)

thanks for using gentoo



------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Benny Pedersen-2
In reply to this post by Phil Stracchino
Phil Stracchino skrev den 2013-11-11 18:50:
> On 11/11/13 12:46, Guillaume Hilt wrote:
>> 5.5 is still in testing.
>
> Is it just me, or is it slightly ridiculous for MySQL 5.5 to be "still
> in testing" three years after its official general-availability
> release?

i think mariadb is in mind ?

no one maked a stable request for 5.5

------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Tom Hendrikx
In reply to this post by Guillaume Hilt-2
Hi

Just a small note that filing a bug in gentoo bugzilla will just come
back here, since I wrote the gentoo ebuild, with some help from Stevan.
It might be interesting if some gentoo mysql folks should jump in.

I'm not really good with the automake/m4 stuff though, so I already
tried to put the voodoo I have. Maybe somebody else has some more ideas?

Are other distros providing a working mysql 5.5 + dspam 3.10?

I'd be interested in seeing dspam tested with stable mariadb though.
Could spend some time on seeing if that compiles tonight. Since I'm
running gentoo with postgres backend, I don't have an easy opportunity
to test with real data though...

Regards,
        Tom

On 11/11/2013 06:46 PM, Guillaume Hilt wrote:

> 5.5 is still in testing.
> Since I use it on my main mysql server (ubuntu 12.04), i have to use it
> on this one too.
>
> I'll post a bug tomorrow.
>
>    Guillaume Hilt
>
> Le 11/11/2013 01:23, Benny Pedersen a écrit :
>> Guillaume Hilt skrev den 2013-11-08 10:05:
>>
>>> I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
>>> up-to-date).
>> is mysql 5.5 unmasked now ?
>>
>> here is just 5.1 on both of my gentoo servers
>>
>> block 5.5 and remerge dspam, but maybe need to emerge stable mysql first
>> ?
>>
>> in any case make a bog on gentoo that dspam blocks mysql 5.5 would be
>> essential
>>
>>
>>
>> ------------------------------------------------------------------------------
>> November Webinars for C, C++, Fortran Developers
>> Accelerate application performance with scalable programming models. Explore
>> techniques for threading, error checking, porting, and tuning. Get the most
>> from the latest Intel processors and coprocessors. See abstracts and register
>> http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
>> _______________________________________________
>> Dspam-user mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/dspam-user
>>
>
>
> ------------------------------------------------------------------------------
> November Webinars for C, C++, Fortran Developers
> Accelerate application performance with scalable programming models. Explore
> techniques for threading, error checking, porting, and tuning. Get the most
> from the latest Intel processors and coprocessors. See abstracts and register
> http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
> _______________________________________________
> Dspam-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/dspam-user
>


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user

signature.asc (919 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Guillaume Hilt-2
Yep, it works well on Ubuntu 12.04 AMD 64 (working on my personal mail server).
Same with MariaDB 5.5 (i had it then an dist-upgrade switched it back to mysql and now i'm too lazy to put mariadb back).
  Guillaume Hilt
Le 12/11/2013 10:25, Tom Hendrikx a écrit :
Hi

Just a small note that filing a bug in gentoo bugzilla will just come
back here, since I wrote the gentoo ebuild, with some help from Stevan.
It might be interesting if some gentoo mysql folks should jump in.

I'm not really good with the automake/m4 stuff though, so I already
tried to put the voodoo I have. Maybe somebody else has some more ideas?

Are other distros providing a working mysql 5.5 + dspam 3.10?

I'd be interested in seeing dspam tested with stable mariadb though.
Could spend some time on seeing if that compiles tonight. Since I'm
running gentoo with postgres backend, I don't have an easy opportunity
to test with real data though...

Regards,
	Tom

On 11/11/2013 06:46 PM, Guillaume Hilt wrote:
5.5 is still in testing.
Since I use it on my main mysql server (ubuntu 12.04), i have to use it 
on this one too.

I'll post a bug tomorrow.

   Guillaume Hilt

Le 11/11/2013 01:23, Benny Pedersen a écrit :
Guillaume Hilt skrev den 2013-11-08 10:05:

I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
up-to-date).
is mysql 5.5 unmasked now ?

here is just 5.1 on both of my gentoo servers

block 5.5 and remerge dspam, but maybe need to emerge stable mysql first
?

in any case make a bog on gentoo that dspam blocks mysql 5.5 would be
essential



------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most 
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user




------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most 
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk


_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Guillaume Hilt-2
In reply to this post by Tom Hendrikx
So, should I fill a bug on Gentoo bugzilla or not ? :)
  Guillaume Hilt
Le 12/11/2013 10:25, Tom Hendrikx a écrit :
Hi

Just a small note that filing a bug in gentoo bugzilla will just come
back here, since I wrote the gentoo ebuild, with some help from Stevan.
It might be interesting if some gentoo mysql folks should jump in.

I'm not really good with the automake/m4 stuff though, so I already
tried to put the voodoo I have. Maybe somebody else has some more ideas?

Are other distros providing a working mysql 5.5 + dspam 3.10?

I'd be interested in seeing dspam tested with stable mariadb though.
Could spend some time on seeing if that compiles tonight. Since I'm
running gentoo with postgres backend, I don't have an easy opportunity
to test with real data though...

Regards,
	Tom

On 11/11/2013 06:46 PM, Guillaume Hilt wrote:
5.5 is still in testing.
Since I use it on my main mysql server (ubuntu 12.04), i have to use it 
on this one too.

I'll post a bug tomorrow.

   Guillaume Hilt

Le 11/11/2013 01:23, Benny Pedersen a écrit :
Guillaume Hilt skrev den 2013-11-08 10:05:

I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
up-to-date).
is mysql 5.5 unmasked now ?

here is just 5.1 on both of my gentoo servers

block 5.5 and remerge dspam, but maybe need to emerge stable mysql first
?

in any case make a bog on gentoo that dspam blocks mysql 5.5 would be
essential



------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most 
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user




------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most 
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk


_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Guillaume Hilt-2
In reply to this post by Benny Pedersen-2
Le 11/11/2013 19:38, Benny Pedersen a écrit :
> Phil Stracchino skrev den 2013-11-11 18:50:
>> On 11/11/13 12:46, Guillaume Hilt wrote:
>>> 5.5 is still in testing.
>> Is it just me, or is it slightly ridiculous for MySQL 5.5 to be "still
>> in testing" three years after its official general-availability
>> release?
> i think mariadb is in mind ?
>
> no one maked a stable request for 5.5
MariaDB is still in testing too.
Sorry, nut no one should have to make a request to have a stable build
of mysql/mariadb5.5, it's not like MySQL isn't widely used.

Le 11/11/2013 19:04, Benny Pedersen a écrit :
>> I'll post a bug tomorrow.
> why wait ? :=)
>
> thanks for using gentoo
Because I wasn't in front of a computer ;)


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Stevan Bajić
In reply to this post by Tom Hendrikx
On 12.11.2013 10:25, Tom Hendrikx wrote:
Hi

Just a small note that filing a bug in gentoo bugzilla will just come
back here, since I wrote the gentoo ebuild, with some help from Stevan.
It might be interesting if some gentoo mysql folks should jump in.

I'm not really good with the automake/m4 stuff though, so I already
tried to put the voodoo I have. Maybe somebody else has some more ideas?

Are other distros providing a working mysql 5.5 + dspam 3.10?
I run over here DSPAM GIT with mySQL 5.5.34:
theia ~ # dspam --version

DSPAM Anti-Spam Suite GIT (agent/library)

Copyright (C) 2002-2012 DSPAM Project
http://dspam.sourceforge.net.

DSPAM may be copied only under the terms of the GNU Affero General Public
License, a copy of which can be found with the DSPAM distribution kit.

Configuration parameters:  '--prefix=/usr' '--build=i686-pc-linux-gnu' '--host=i686-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--with-storage-driver=hash_drv,mysql_drv' '--with-dspam-home=/var/spool/dspam' '--sysconfdir=/etc/mail/dspam' '--enable-daemon' '--disable-external-lookup' '--enable-clamav' '--enable-large-scale' '--disable-domain-scale' '--enable-syslog' '--disable-debug' '--disable-bnr-debug' '--disable-verbose-debug' '--enable-split-configuration' '--enable-long-usernames' '--with-dspam-group=dspam' '--with-dspam-home-group=dspam' '--with-dspam-mode=2511' '--with-logdir=/var/log/dspam' '--with-mysql-includes=/usr/include/mysql' '--with-mysql-libraries=/usr/lib' '--enable-virtual-users' '--enable-preferences-extension' '--disable-homedir' 'build_alias=i686-pc-linux-gnu' 'host_alias=i686-pc-linux-gnu' 'CC=i686-pc-linux-gnu-gcc' 'CFLAGS=-march=native -O2 -pipe -fweb -frename-registers -ftree-loop-optimize -ftree-vectorize -ftree-vectorizer-verbose=1 -floop-interchange -floop-strip-mine -floop-block -freorder-blocks-and-partition -fgcse-sm -fgcse-las -maccumulate-outgoing-args -funswitch-loops -ftracer -fprefetch-loop-arrays -fno-ident -fno-strict-overflow -mfpmath=sse -mmmx -msse -msse2' 'LDFLAGS=-Wl,-O1 -Wl,--as-needed -Wl,-O1 -Wl,--add-needed -Wl,--as-needed -Wl,--hash-style=both -Wl,--sort-common'

theia ~ # mysql --version
mysql  Ver 14.14 Distrib 5.5.34, for Linux (i686) using readline 6.2
theia ~ #

I'd be interested in seeing dspam tested with stable mariadb though.
Could spend some time on seeing if that compiles tonight. Since I'm
running gentoo with postgres backend, I don't have an easy opportunity
to test with real data though...

Regards,
	Tom

-- 
 Kind Regards from Switzerland,

 Stevan Bajić


On 11/11/2013 06:46 PM, Guillaume Hilt wrote:
5.5 is still in testing.
Since I use it on my main mysql server (ubuntu 12.04), i have to use it 
on this one too.

I'll post a bug tomorrow.

   Guillaume Hilt

Le 11/11/2013 01:23, Benny Pedersen a écrit :
Guillaume Hilt skrev den 2013-11-08 10:05:

I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
up-to-date).
is mysql 5.5 unmasked now ?

here is just 5.1 on both of my gentoo servers

block 5.5 and remerge dspam, but maybe need to emerge stable mysql first
?

in any case make a bog on gentoo that dspam blocks mysql 5.5 would be
essential



------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most 
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user




------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most 
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk


_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

ML mail
In reply to this post by Tom Hendrikx
Hi Tom,

Just to mention I am running Debian 7 with the distribution packages of dspam but instead of MySQL, PostgreSQL. Works like a charm! I believe that it will work very well also with MySQL.

Cheers,
ML



On Tuesday, November 12, 2013 10:32 AM, Tom Hendrikx <[hidden email]> wrote:
Hi

Just a small note that filing a bug in gentoo bugzilla will just come
back here, since I wrote the gentoo ebuild, with some help from Stevan.
It might be interesting if some gentoo mysql folks should jump in.

I'm not really good with the automake/m4 stuff though, so I already
tried to put the voodoo I have. Maybe somebody else has some more ideas?

Are other distros providing a working mysql 5.5 + dspam 3.10?

I'd be interested in seeing dspam tested with stable mariadb though.
Could spend some time on seeing if that compiles tonight. Since I'm
running gentoo with postgres backend, I don't have an easy opportunity
to test with real data though...

Regards,
    Tom

On 11/11/2013 06:46 PM, Guillaume Hilt wrote:

> 5.5 is still in testing.
> Since I use it on my main mysql server (ubuntu 12.04), i have to use it
> on this one too.
>
> I'll post a bug tomorrow.
>
>    Guillaume Hilt
>
> Le 11/11/2013 01:23, Benny Pedersen a écrit :
>> Guillaume Hilt skrev den 2013-11-08 10:05:
>>
>>> I recently upgraded from MySQL 5.1.70 to 5.5.32 (on Gentoo AMD64
>>> up-to-date).
>> is mysql 5.5 unmasked now ?
>>
>> here is just 5.1 on both of my gentoo servers
>>
>> block 5.5 and remerge dspam, but maybe need to emerge stable mysql first
>> ?
>>
>> in any case make a bog on gentoo that dspam blocks mysql 5.5 would be
>> essential
>>
>>
>>
>> ------------------------------------------------------------------------------
>> November Webinars for C, C++, Fortran Developers
>> Accelerate application performance with scalable programming models. Explore
>> techniques for threading, error checking, porting, and tuning. Get the most
>> from the latest Intel processors and coprocessors. See abstracts and register
>> http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
>> _______________________________________________
>> Dspam-user mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/dspam-user
>>
>
>
> ------------------------------------------------------------------------------
> November Webinars for C, C++, Fortran Developers
> Accelerate application performance with scalable programming models. Explore
> techniques for threading, error checking, porting, and tuning. Get the most
> from the latest Intel processors and coprocessors. See abstracts and register
> http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
> _______________________________________________
> Dspam-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/dspam-user
>


------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk

_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user



------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Nathanael D. Noblet
In reply to this post by Tom Hendrikx
On 11/12/2013 02:25 AM, Tom Hendrikx wrote:

> Hi
>
> Just a small note that filing a bug in gentoo bugzilla will just come
> back here, since I wrote the gentoo ebuild, with some help from Stevan.
> It might be interesting if some gentoo mysql folks should jump in.
>
> I'm not really good with the automake/m4 stuff though, so I already
> tried to put the voodoo I have. Maybe somebody else has some more ideas?
>
> Are other distros providing a working mysql 5.5 + dspam 3.10?

Fedora 20 has mariadb 5.5.33a-2 and dspam 3.10. I'm the dspam maintainer
for fedora. I don't know if I've 'tested' it other than it compiles. I
tend to use dspam on more long term distros like centos etc..
--
Nathanael d. Noblet
t 403.875.4613

------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Phil Stracchino
In reply to this post by Tom Hendrikx
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On 11/12/13 04:25, Tom Hendrikx wrote:

> Hi
>
> Just a small note that filing a bug in gentoo bugzilla will just
> come back here, since I wrote the gentoo ebuild, with some help
> from Stevan. It might be interesting if some gentoo mysql folks
> should jump in.
>
> I'm not really good with the automake/m4 stuff though, so I
> already tried to put the voodoo I have. Maybe somebody else has
> some more ideas?
>
> Are other distros providing a working mysql 5.5 + dspam 3.10?


I note for the record that I have dev-db/mysql-5.5.33 and
mail-filter/dspam-3.10.2-r1 working fine together with
mail-mta/postfix-2.10.2.  It did take some tweaking of file
permissions on dspam, but I don't at this point remember what specific
changes I had to make.  I use dspam in re-injection mode via a filter:


smtp      inet  n       -       n       -       -       smtpd
        -o content_filter=dspam:

dspam unix - n n - - pipe
        flags=Rhq user=dspam argv=/usr/bin/dspamfilter -f ${sender} --
${recipient}



#!/bin/bash
USER=`echo $4 | cut -d@ -f1`
HOST=`echo $4 | cut -d@ -f2`

if [ -f /etc/dspam/nodspam ] ; then
{
    # Passthrough because Dspam deactivated
    echo "Passthrough at `date`: dspam turned off" >>
/var/log/dspamfilter.log
    /usr/lib/sendmail -i "$@"
}
elif [ -n "`echo $4 | grep
'\(nejob\|-\(bounces\|request\|admin\)\?\)\@caerllewys.net'`" ] ; then
{
    # pass MailMan traffic through
    echo "Passthrough at `date`: Mailman traffic for $4" >>
/var/log/dspamfilter.log
    /usr/lib/sendmail -i "$@"
}
elif [ -n "`echo $HOST | grep caerllewys.net`" ] ; then
{
    # Process all other external mail through dspam
    echo "Mail for $4 processed by dspam at `date`" >>
/var/log/dspamfilter.log
    id >> /var/log/dspamfilter.log
    /usr/bin/dspam --deliver=innocent --stdout --user $USER |
/usr/lib/sendmail -i "$@"
}
else
{
    # Passthrough local mail
    echo "Passthrough at `date`: local delivery" >>
/var/log/dspamfilter.log
    id >> /var/log/dspamfilter.log
    /usr/lib/sendmail -i "$@"
    USER=$4
}
fi;

exit $?



- --
  Phil Stracchino
  Babylon Communications
  [hidden email]
  [hidden email]
  Landline: 603.293.8485
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.22 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iEYEAREIAAYFAlKCWC4ACgkQ0DfOju+hMkn4sQCgxO0nNQX8V6LToZUpF8OSSXJh
otoAoIVwXCrqcudcHJh4v5/vp52iZtYH
=0oaJ
-----END PGP SIGNATURE-----

------------------------------------------------------------------------------
November Webinars for C, C++, Fortran Developers
Accelerate application performance with scalable programming models. Explore
techniques for threading, error checking, porting, and tuning. Get the most
from the latest Intel processors and coprocessors. See abstracts and register
http://pubads.g.doubleclick.net/gampad/clk?id=60136231&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Benny Pedersen-2
In reply to this post by Guillaume Hilt-2
Guillaume Hilt skrev den 2013-11-12 10:45:

> Because I wasn't in front of a computer ;)

perfect for android



------------------------------------------------------------------------------
DreamFactory - Open Source REST & JSON Services for HTML5 & Native Apps
OAuth, Users, Roles, SQL, NoSQL, BLOB Storage and External API Access
Free app hosting. Or install the open source package on any LAMP server.
Sign up and see examples for AngularJS, jQuery, Sencha Touch and Native!
http://pubads.g.doubleclick.net/gampad/clk?id=63469471&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Benny Pedersen-2
In reply to this post by Tom Hendrikx
Tom Hendrikx skrev den 2013-11-12 10:25:

> Just a small note that filing a bug in gentoo bugzilla will just come
> back here, since I wrote the gentoo ebuild, with some help from Stevan.
> It might be interesting if some gentoo mysql folks should jump in.

would be nice to see how gentoo solve mysql/mariadb with blocks first,
can both be used in same time ?

with diff socket/inet listners it should not be a problem, but client
api in dspam should need to know with one imho for elf codes selecting
:=)

> I'm not really good with the automake/m4 stuff though, so I already
> tried to put the voodoo I have. Maybe somebody else has some more
> ideas?

i alos just that problematic developer with my fidonet overlay, if it
works it works, if its not works seek help or make it work :=)

> Are other distros providing a working mysql 5.5 + dspam 3.10?

in ubuntu 12.04.3 lts there is just 3.10.1 and build default with
postgresql backend

> I'd be interested in seeing dspam tested with stable mariadb though.

i have seen ones that have changed says its working better then mysql,
so hopefully its wort doing

> Could spend some time on seeing if that compiles tonight. Since I'm
> running gentoo with postgres backend,

that reminds me of trying change from mysql to postgresql, in
successfull, and i ended just used spamassassin bayes with on it own
have problem with poison learning on maillists

> I don't have an easy opportunity to test with real data though...

excactly why i ended dropping dspam, data is not raw compatibel between
backends, would be nice to see dspam as milter, amavisd-new have limit
dspam support, but Mark admit untested



------------------------------------------------------------------------------
DreamFactory - Open Source REST & JSON Services for HTML5 & Native Apps
OAuth, Users, Roles, SQL, NoSQL, BLOB Storage and External API Access
Free app hosting. Or install the open source package on any LAMP server.
Sign up and see examples for AngularJS, jQuery, Sencha Touch and Native!
http://pubads.g.doubleclick.net/gampad/clk?id=63469471&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Benny Pedersen-2
In reply to this post by Guillaume Hilt-2
Guillaume Hilt skrev den 2013-11-12 10:36:
> So, should I fill a bug on Gentoo bugzilla or not ? :)

stable req on mysql 5.5
blocker on dspam not working on mysql 5.5 so possible it gets tracked
here on maillist aswell for route to hell :=)



------------------------------------------------------------------------------
DreamFactory - Open Source REST & JSON Services for HTML5 & Native Apps
OAuth, Users, Roles, SQL, NoSQL, BLOB Storage and External API Access
Free app hosting. Or install the open source package on any LAMP server.
Sign up and see examples for AngularJS, jQuery, Sencha Touch and Native!
http://pubads.g.doubleclick.net/gampad/clk?id=63469471&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
Reply | Threaded
Open this post in threaded view
|

Re: [Dspam-user] Unable to recompile DSPAM on Gentoo since MySQL upgrade

Guillaume Hilt-2
I'm filling 2 bugs as is it different issues.

DSPAM with MySQL 5.5.32 : https://bugs.gentoo.org/show_bug.cgi?id=491156
MySQL stable : https://bugs.gentoo.org/show_bug.cgi?id=491158

   Guillaume Hilt

Le 12/11/2013 21:56, Benny Pedersen a écrit :

> Guillaume Hilt skrev den 2013-11-12 10:36:
>> So, should I fill a bug on Gentoo bugzilla or not ? :)
> stable req on mysql 5.5
> blocker on dspam not working on mysql 5.5 so possible it gets tracked
> here on maillist aswell for route to hell :=)
>
>
>
> ------------------------------------------------------------------------------
> DreamFactory - Open Source REST & JSON Services for HTML5 & Native Apps
> OAuth, Users, Roles, SQL, NoSQL, BLOB Storage and External API Access
> Free app hosting. Or install the open source package on any LAMP server.
> Sign up and see examples for AngularJS, jQuery, Sencha Touch and Native!
> http://pubads.g.doubleclick.net/gampad/clk?id=63469471&iu=/4140/ostg.clktrk
> _______________________________________________
> Dspam-user mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/dspam-user
>


------------------------------------------------------------------------------
DreamFactory - Open Source REST & JSON Services for HTML5 & Native Apps
OAuth, Users, Roles, SQL, NoSQL, BLOB Storage and External API Access
Free app hosting. Or install the open source package on any LAMP server.
Sign up and see examples for AngularJS, jQuery, Sencha Touch and Native!
http://pubads.g.doubleclick.net/gampad/clk?id=63469471&iu=/4140/ostg.clktrk
_______________________________________________
Dspam-user mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/dspam-user
12